Bad Cowtractors POJ - 2377(Kruskal算法+最大生成树)

题目:

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

题意:

把N个节点生成一个生成树,不过是最大生成树;

思路:

直接使用最小生成树中的Kruskal算法,把代码进行简单的修改,每次加入生成树的边都是选择符合题意的最大的边;

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int N=5000;

struct node//存储每一条边
{
    int from;
    int to;
    int w;
} a[N*10];

bool cmp(node aa,node bb)//排序
{
    return aa.w>bb.w;
}

int n,m,k,t;
int f[N];//存储每一个点的父亲节点

int getf(int v)//寻找父亲节点;
{
    if(f[v]==v)
        return f[v];
    else
        return f[v]=getf(f[v]);
}

int Kruskal()
{
    sort(a,a+k,cmp);//按照边的权值由小到大进行排序;
    int ans=0,countt=1;
    for(int i=0; i<k; i++)
    {
        int t1=getf(a[i].from);
        int t2=getf(a[i].to);
        if(t1!=t2)//父亲节点不同,不会构成环路;
        {
            ans+=a[i].w;
            f[t2]=t1;//把父亲节点改成相同;
            countt++;
            if(countt==n)//如果加入n条边就可以结束了;
                break;
        }
    }
    if(countt==n)
        return ans;
    else
        return -1;
}

int main()
{
    scanf("%d%d",&n,&k);
    for(int i=0; i<k; i++)
    {
        scanf("%d%d%d",&a[i].from,&a[i].to,&a[i].w);
    }
    for(int i=0; i<=N; i++) //初始化,自己的父亲节点是自己;
        f[i]=i;
    int kk=Kruskal();
    printf("%d\n",kk);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值