Can you solve this equation

G. Can you solve this equation?

TimeLimit: 1000ms

2017.12.10

64-bitinteger IO format: %I64d     Java class name: Main

Submit Status

Now,giventhe equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solutionbetween 0 and 100;
Now please try your lucky.

Input 

Thefirst line of the input contains an integer T(1<=T<=100) which means thenumber of test cases. Then T lines follow, each line has a real number Y(fabs(Y) <= 1e10);

Output 

Foreach test case, you should just output one real number(accurate up to 4 decimalplaces),which is the solution of the equation,or “No solution!”,if there is nosolution for the equation between 0 and 100.

Sample Input 

2

100

-4

Sample Output 

1.6152

#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
    double f(double x);
    int t,j;
    scanf("%d",&t);
    for(j=0;j<t;j++)
    {
        double y,x=0.0,m,l=100;
        scanf("%lf",&y);
        if((f(0)-y)*(f(100)-y)>0)
            printf("No solution!\n");
        else
        {
            while(fabs(l-x)>0.000001)
            {
                m=(l+x)/2;
                if(f(m)-y>0)
                    l=m;
                else
                    x=m;
            }
            printf("%.4lf\n",m);
        }
        
    }
    return 0;
}
double f(double x)
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;

Nosolution!

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值