A - Can you solve this equation?

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.
InputThe first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);OutputFor each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.Sample Input
2
100
-4
Sample Output
1.6152
No solution!


思路:这题很明显就是利用二分的思想,先行判断函数是否为单调的,只有单调的才能够使用二分法,不断的逼近正确值,但要给一个精度值(要足够小),才能满足题意。一般的时候取1e-8,最后要求给出的小数点越多,这里的精度值就要越高。

#include <iostream>
#include <algorithm>
#include <string>
#include <string.h>
#include <iomanip>
using namespace std;
int check(double x,double y)
{
if (y - (8.0*pow(x, 4) + 7.0*pow(x, 3) + 2.0*pow(x, 2) + 3.0*x + 6)<0)
return 1;
else
return 0;
}
int main()
{
int T;
cin >> T;
while (T--)
{
double Y;
cin >> Y;
double left = 0, right = 100;
double mid;
if (Y < 6 || Y>807020306)
cout << "No solution!" << endl;
else
{
while (right - left > 1e-8)
{
mid = (left + right) / 2.0;
if (check(mid, Y))
right = mid;
else
left = mid;
}
cout << fixed << setprecision(4) << mid << endl;
}
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值