【算法练习】图论/Floyd最短路 百练poj1603:Risk

题目链接:http://bailian.openjudge.cn/practice/1603

1603:Risk

总时间限制: 

1000ms

 

内存限制: 

65536kB

描述

Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player's turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country. 

During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one. 

The following connection diagram illustrates the first sample input. 

输入

Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest. 

There can be multiple test sets in the input file; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.

输出

For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.

样例输入

1 3
2 3 4
3 4 5 6
1 6
1 7
2 12 13
1 8
2 9 10
1 11
1 11
2 12 17
1 14
2 14 15
2 15 16
1 16
1 19
2 18 19
1 20
1 20
5
1 20
2 9
19 5
18 19
16 20

样例输出

Test Set #1
1 to 20: 7
2 to 9: 5
19 to 5: 6
18 to 19: 2
16 to 20: 2

题目很简单,用简单的Floyd就可AC,

但是不知道为啥我一开始处理的输入就是cin.peek()!=EOF

此时是不可以AC的 也不知道处理输入上有一些什么问题。。现在还没有明白

 

AC代码:

#include<iostream>
using namespace std;
int G[30][30];
int cases=1;
int N,t,T;
int x,y;
int main(){
    while(cin>>N){
        //初始化

        for(int i=1;i<21;i++){
            for(int j=1;j<21;j++){
                G[i][j]=-1;
            }
            G[i][i]=0;
        }
        for(int i=0;i<N;i++){
            cin>>t;
            G[1][t]=G[t][1]=1;
        }
        for(int i=2;i<=19;i++){
            cin>>N;
            for(int j=0;j<N;j++){
                cin>>t;
                G[i][t]=G[t][i]=1; //无向图
            }
        }

        //输入
        //求最短路
        for(int k=1;k<=20;k++){
            for(int i=1;i<=20;i++){
                for(int j=1;j<=20;j++){
                    if(G[i][k]==-1 || G[k][j]==-1) continue;
                    if(G[i][j]==-1 || G[i][k]+G[k][j]<G[i][j]){
                        G[i][j]=G[i][k]+G[k][j];
                    }
                }
            }
        }

        //输出答案
        cin>>T;
        cout<<"Test Set #"<<cases<<endl;
        for(int i=0;i<T;i++){
            cin>>x>>y;
            cout<<x<<" to "<<y<<": "<<G[x][y]<<endl;
        }
        cout<<endl;
        cases++;
    }

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值