HDU - 4217 - Data Structure?(线段树)

#HDU - 4217 - Data Structure?
Data structure is one of the basic skills for Computer Science students, which is a particular way of storing and organizing data in a computer so that it can be used efficiently. Today let me introduce a data-structure-like problem for you.
Original, there are N numbers, namely 1, 2, 3…N. Each round, iSea find out the Ki-th smallest number and take it away, your task is reporting him the total sum of the numbers he has taken away.
Input
The first line contains a single integer T, indicating the number of test cases.
Each test case includes two integers N, K, K indicates the round numbers. Then a line with K numbers following, indicating in i (1-based) round, iSea take away the Ki-th smallest away.

Technical Specification

  1. 1 <= T <= 128
  2. 1 <= K <= N <= 262 144
  3. 1 <= Ki <= N - i + 1
    Output
    For each test case, output the case number first, then the sum.
    Sample Input
    2
    3 2
    1 1
    10 3
    3 9 1
    Sample Output
    Case 1: 3
    Case 2: 14
    题目链接

给你测试样例的个数,然后是n,m,n是数字的个数,即从1到n,m是m组询问,接下来m个数字k是问第k大的数字,每次被询问完之后,该数字就从数字串中删除。最后求询问的和。
还是建树,将val用来记录区间长度,如果k小于等于左区间长度就在左孩子里找,否则去右孩子找,在右孩子找的时候,要减去左边区间长度,因为要看在右孩子里的第几个。

#include <cstdio>
#include <vector>
#include <iostream>
#define ll long long
using namespace std;
const int maxn = 4e6 + 5;

struct node
{
    ll l, r, val;
}p[maxn];

void build(ll l, ll r, ll cur)
{
    p[cur].l = l, p[cur].r = r;
    p[cur].val = r - l + 1;
    if(l == r)  return ;
    ll m = (l + r) >> 1;
    build(l, m, cur << 1);
    build(m + 1, r, cur << 1 | 1);
}

ll query(ll pos, ll cur)
{
    ll l = p[cur].l, r = p[cur].r;
    p[cur].val--;
    if(l == r)  return l;
    if(p[cur << 1].val >= pos) return query(pos, cur << 1);
    else    return query(pos - p[cur << 1].val, cur << 1 | 1);
}

int main()
{
    ll t, ans, n, m;
    scanf("%lld", &t);
    for(int test = 1; test <= t; test++)
    {
        ans = 0;
        scanf("%lld%lld", &n, &m);
        build(1, n, 1);
        for(int i = 0; i < m; i++)
        {
            ll pos;
            scanf("%lld", &pos);
            ans += query(pos, 1);
        }
        printf("Case %d: %lld\n", test, ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值