POJ - 1458 - Common Subsequence(dp & 公共子串)

POJ - 1458 - Common Subsequence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, …, xm > another sequence Z = < z1, z2, …, zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, …, ik > of indices of X such that for all j = 1,2,…,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
**Sample Output
4
2
0

题目链接
题意是让你从两个字符串中找最长的公共子串的长度。
这个我也是看的题解,貌似是一个模板题,需要一个dp二维数组,行列分别代表了题目中的两个字符串。dp[i][j]代表第一个字符串到第 i 个字符,第二个字符串到第 j 个字符的时候两个字符最长的公共子串的长度。所以,当s[i] == t[j]的时候,那么公共子串的长度又在原来的基础上大了1,否则就从dp[i + 1][j], dp[i][j + 1]前面找到的子串长度中选一个最长的。
则有了这样的代码

if(s[i] == t[j]) dp[i + 1][j + 1] = dp[i][j] + 1;
else dp[i + 1][j + 1] = max(dp[i + 1][j], dp[i][j + 1]);

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
const int maxn = 1e3 + 5;
int dp[maxn][maxn];

 int main()
 {
    int n;
    string s, t;
    while(cin >> s >> t)
    {
        memset(dp, 0, sizeof(dp));
        int ls = s.length();
        int lt = t.length();
        for(int i = 0; i < ls; i++)
            for(int j = 0; j < lt; j++)
            {
                if(s[i] == t[j])    dp[i + 1][j + 1] = dp[i][j] + 1;
                else dp[i + 1][j + 1] = max(dp[i + 1][j], dp[i][j + 1]);
            }
        cout << dp[ls][lt] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值