HDU - 1022 - Train Problem I(栈的应用)

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

这里写图片描述这里写图片描述这里写图片描述

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.
Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.”.

就是说给一个数 n ,代表了火车的数量,一个火车站只有一个出口,如图,A车进了,然后B车如果再进,那么A车如果想出只能等B车先出,其实就是一个栈。每一个火车都有一个编号,给你两个顺序,然后问你能不能通过这个火车站(栈)实现将前面那个顺序变成后面的顺序。

其实就是压栈和出栈的过程,我的思想是,不管遇到什么,先压栈,然后判断是否和要变成的顺序当前位置的火车编号相等,如果相等的话那么就直接出栈,然后再把转变后的顺序的当前位置后移,让所有火车都这样遍历一遍,然后把栈里剩下的火车开出来,判断是否跟剩下的转变后的顺序相同,这个过程还需要用一个数组记录他进出的顺序。具体见代码

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;
const int maxn = 5e2 + 5;
int og[maxn], en[maxn], tr[maxn << 1];
int n, cnt, cen;
char c;

int main()
{
	//freopen("C:\\Users\\Administrator\\Desktop\\in.txt", "r", stdin);
	//freopen("C:\\Users\\Administrator\\Desktop\\out.txt", "w", stdout);
	while(~scanf("%d", &n))
	{
		cen = cnt = 0;
		getchar();
		for(int i = 0; i < n; i++)
		{
			c = getchar();
			og[i] = c - '0';
		}
		getchar();
		for(int i = 0; i < n; i++)
		{
			c = getchar();
			en[i] = c - '0';
		}
		stack<int> s;
		for(int i = 0; i < n; i++)
		{
			s.push(og[i]);
			tr[cnt++] = 1;
			while(s.size() && s.top() == en[cen])
			{
				tr[cnt++] = 2;
				s.pop();
				cen++;
			}
		}
		while(s.size())
		{
			if(s.top() == en[cen])
			{
				tr[cnt++] = 2;
				s.pop();
				cen++;
			}
			else	break ;
		}
		if(s.size())
		{
			printf("No.\nFINISH\n");
			continue ;
		}
		printf("Yes.\n");
		for(int i = 0; i < cnt; i++)
		{
			if(tr[i] == 1)	printf("in\n");
			else	printf("out\n");
		} 
		printf("FINISH\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值