HDU-1087 - Super Jumping! Jumping! Jumping!(dp & 求子串)

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

这里写图片描述

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0
Sample Output
4
10
3

题目告诉你要从起点到达终点要经过一定数量的棋子,每个棋子都有自己的价值,并且要求走过的棋子必须严格递增。每走过一个棋子就能获得该棋子的价值,问你最大能获得多少价值。

题目告诉你让你找一个上升子序列(严格上升,不能等于,这也算是个坑点),使得这个子序列的价值最大。那么我们就遍历每一步,没到一步,就循环找到前面比该点价值小的点(因为要严格递增),并且走到这一点价值还是最大。如果存在这样的节点的话,那么就在该点加上前面找到的最大价值,如果找不到,就说明前面的点都比他大,那么到该点能构成的字串的最大价值只能是他自己本身的价值。这里我们用一个数组记录每一个点的价值,再申请一个dp数组。
dp[i]代表到i点为止能够形成的子串所得到的最大价值。

具体代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 1e3 + 5, inf = 0x3f3f3f3f;
int dp[maxn], v[maxn], w[maxn], a[maxn];

int main()
{
    int t, n, m;
    while(scanf("%d", &n), n)
    {
        memset(dp, 0, sizeof(dp));  //记得初始化dp数组
    //记录每一步所能获得的价值
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
    //第一个点前面没有点了,所以走到这一步构成的子串所获得的最大价值就是它本身
        dp[1] = a[1];
    //从第二步开始往后走,遍历每一个点的价值
        for(int i = 2; i <= n; i++)
        {
            int _max = -1;
        //找他前面的每一个点,看点的值比他小,并且构成子串的最大价值
            for(int j = 1; j <= i - 1; j++)
                if(a[j] < a[i] && dp[j] > _max) _max = dp[j];
        //如果找到,就在自身价值和前面子串加上自身价值中选择一个最大值,如果找不到那么就说明前面每个点的值都比他大,他能构成的子串只有自己一个元素
            if(_max != -1)  dp[i] = max(a[i], _max + a[i]);
            else    dp[i] = a[i];
        }
        int _max = -1;
    //找到所有的子串,挑选所有子串中价值最大的一个输出
        for(int i = 1; i <= n; i++) _max = max(_max, dp[i]);
        printf("%d\n", _max);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值