POJ - 2492 - A Bug's Life (种类并查集)

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
Hint
Huge input,scanf is recommended.
题目链接

在虫子里面找同性恋,如果给的条件里面,由于以前的条件冲突的话,那么就是同性恋了。还有一个类似的题目,那就是食物链,这里是题解,都是一样的方法,可以直接用向量法,很好用。可以看一下食物链的题解。,下面直接上代码:

AC代码:

#include<cstdio>
#include<iostream>
using namespace std;

int root[2010], rel[2010], flag;

int Find(int x)
{
    if(root[x] == x)    return x;
    int r = Find(root[x]);
    rel[x] = (rel[x] + rel[root[x]])%2;
    return root[x] = r;
}

void unit(int a, int b)
{
    int x = Find(a), y = Find(b);
    if(x == y)
    {
        if(rel[a] == rel[b])    flag = 1;
        return ;
    }
    root[y] = x;
    rel[y] = (rel[a]+rel[b]+1)%2;
}

int main()
{
    int T;
    scanf("%d", &T);
    for(int test = 1; test <= T; test++)
    {
        int n, k;
        scanf("%d%d", &n, &k);
        flag = 0;
        for(int i = 0; i <= n; i++)
            root[i]=i, rel[i]=0;
        while(k--)
        {
            int a, b;
            scanf("%d%d",&a, &b);
            if(flag)
                continue;
            unit(a, b);
        }
        printf("Scenario #%d:\n",test);
        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值