Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
You can assume that the grass in the board would never burn out and the empty grid would never get fire.
Note that the two grids they choose can be the same.
Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1 <= T <=100, 1 <= n <=10, 1 <= m <=10
Output
For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.
Sample Input
4 3 3 .#. ### .#. 3 3 .#. #.# .#. 3 3 ... #.# ... 3 3 ### ..# #.#
Sample Output
Case 1: 1 Case 2: -1 Case 3: 0 Case 4: 2
暴力枚举每两个草堆,找出时间最少的
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
#define inf 0x3f3f3f3f
struct node
{
int x,y,k;
};
char map[15][15];
vector<node>v;
int vis[15][15],n,m;
int ans=inf;
bool check(int xx,int yy)//判断是不是草堆以及在不在地图范围内
{
if(xx>=0&&yy>=0&&xx<n&&yy<m&&vis[xx][yy]==0&&map[xx][yy]=='#')return true;
return false;
}
bool judge()//判断是否所有草堆烧完了
{
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
if(map[i][j]=='#'&&!vis[i][j])
return false;
}
return true;
}
int bfs(node a,node b)
{
memset(vis,0,sizeof(vis));
queue<node>q;
q.push(a);q.push(b);
int depthest=0;
while(!q.empty())
{
node now=q.front();
q.pop();
if(vis[now.x][now.y]) continue;
vis[now.x][now.y]=1;
depthest=now.k;//更新时间
if (check(now.x-1,now.y))
{
node nxt=now;
nxt.x--;
nxt.k++;
q.push(nxt);
}
if (check(now.x+1,now.y))
{
node nxt=now;
nxt.x++;
nxt.k++;
q.push(nxt);
}
if (check(now.x,now.y-1))
{
node nxt=now;
nxt.y--;
nxt.k++;
q.push(nxt);
}
if (check(now.x,now.y+1))
{
node nxt=now;
nxt.y++;
nxt.k++;
q.push(nxt);
}
}
return depthest;
}
int main()
{
int T;
cin>>T;
for(int o=1;o<=T;o++)
{
ans=inf;
v.clear();
memset(vis,0,sizeof(vis));
cin>>n>>m;
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
{
cin>>map[i][j];
if(map[i][j]=='#')
{
node u;
u.x=i;u.y=j;u.k=0;
v.push_back(u);
}
}
for(int i=0;i<v.size();i++)//暴力枚举每两个草堆作为最开始点燃的草堆
{
for(int j=i;j<v.size();j++)
{
v[i].k=0;v[j].k=0;
int temp=bfs(v[i],v[j]);
if(judge())ans=min(ans,temp);//找到时间最短的
}
}
printf("Case %d: ",o);
if(ans==inf)printf("-1\n");
else printf("%d\n",ans);
}
return 0;
}