ACM-ICPC北京赛区2018现场赛 A题

在金庸逝世的纪念会上,粉丝们争论金庸小说中角色的武功高低,你作为一个EECS学校的程序员,需要找出首次出现的矛盾言论。
摘要由CSDN通过智能技术生成

Jin Yong’s Wukong Ranking List

时间限制:1000ms

单点时限:1000ms

内存限制:512MB

描述

Jin Yong was the most famous and popular Chinese wuxia (The one who fight bad people by his Wukong i.e. Wushu and Kongfu) novelist who lived in Hong Kong. Between 1955 and 1972, he wrote 14 novels which earned him a reputation as one of the greatest and most popular Chinese writers. Over 100 million copies of his works have been sold worldwide,not including a countless number of pirated copies. Jin Yong’s works seem to have magic. Once you begin to read a novel of his, you just can’t stop until you finish it.

Last month, Jin Yong passed away at the age of 94. Many Jin Yong’s fans in PKU held a meeting to memorize him. Jin Yong’s fans always like to discuss or argue or even quarrel about whose Wukong are better among the wuxia characters of his novel. During the meeting, this happened again:

Every fans said some words like "Qiao Feng's Wukong is better than Guo Jing's". Obviously, those words may contradict each other and then cause quarrels. As a boring and girlfriendless male programmer of EECS school, you always want to make some things. So you are eager to point out the contradictions as soon as possible. That means, you want to find out the first one whose words contradict the words said by others before him.

Please note that if A is better than B, and B is better than C, then of course A must be better than C.

输入

There are no more than 15 test cases.

For each test case:

The first line is an integer n( 1 <= n <=20), meaning that there are n sentences.

The following n lines are those n sentences which is in the format below:

s1 s2

This means someone said that s1's Wukong was better than s2's. Both s1 and s2 are names of Jin Yong's characters which consists of only English letters. It's guaranteed that s1 and s2 are different, and their length is no more than 30. Names are case sensitive.

输出

For each test case, print the first sentence which cause a contradiction. If there are no contradiction, print 0 instead.

提示

DON'T try to figure out who are those names in the sample and waste your time.

样例输入

2
BrokenReputation ExtinctNun
HelloLaught EnvelopeNotFlat
6
LandOverWind LonelyLight
FireMonk CutTheForest
CutTheForest LookCrazy
MakeFoxRush LetMeGo
HeroAunt UniqueLand
LookCrazy FireMonk

样例输出

0
LookCrazy FireMonk

只要一层一层查找上去,判断是否出现矛盾即可。

#include<bits/stdc++.h>
using namespace std;

map<string,bool>vis;
map<string,int>q;
int father[101];

int find(int x,int y)//判断x的父亲里是否出现过 y 
{
	if(x==y)return 0;
	if(father[x]==x)return 1;
	return find(father[x],y);
}

int main()
{
	int n;
	while(cin>>n)
	{
		if(!n)break;
		vis.clear();
		q.clear();
		for(int i=1;i<=100;i++)
		{
			father[i]=i;
		}
		string s1,s2,ss1,ss2;
		int num=0;
		int ff=0;
		for(int i=1;i<=n;i++)
		{
			cin>>s1>>s2;
			if(ff)continue;
			if(vis[s1]==0)
			{
				vis[s1]=1;
				q[s1]=++num;
			}
			if(vis[s2]==0)
			{
				vis[s2]=1;
				q[s2]=++num;
			}
			int f=find(q[s1],q[s2]);
			if(f)father[q[s2]]=q[s1];
			else 
			{
				ff=i;
				ss1=s1,ss2=s2;
			}
		}
		if(ff)cout<<ss1<<" "<<ss2<<endl;
		else cout<<"0"<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值