poj 2299 (树状数组,归并排序+读入优化)

因数据量大,读入优化大概能快100多毫秒。

Ultra-QuickSort

Time Limit: 7000 MS Memory Limit: 65536 KB

64-bit integer IO format: %I64d , %I64u Java class name: Main

[Submit] [Status] [Discuss]

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define L long
#define MAXN 500005
#define LL long long
using namespace std;
L a[MAXN];L temp[MAXN];
LL sum=0;
void read(L &x)
{
    int f=1;x=0;char s=getchar();
    while(s<'0'||s>'9'){if(s=='-')f=-1;s=getchar();}
    while(s>='0'&&s<='9'){x=x*10+s-'0';s=getchar();}
     x*=f;
}
void Mergesort(int b,int mid,int e)
{
    int lf=b;int rg=mid+1;
    int cnt=0;
    while(lf<=mid&&rg<=e)
    {
        if(a[lf]>a[rg])
        {
            temp[cnt++]=a[rg++];
            sum+=mid-lf+1;
        }
        else temp[cnt++]=a[lf++];
    }
    while(lf<=mid)
      temp[cnt++]=a[lf++];
    while(rg<=e)
      temp[cnt++]=a[rg++];
    for(int i=0;i<cnt;i++)
    {
        a[b+i]=temp[i];
    }
}
void Merge(int be,int en)
{
    if(be>=en)
       return ;
    else{
        int mid=(be+en)/2;
        Merge(be,mid);
        Merge(mid+1,en);
        Mergesort(be,mid,en);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n) && n)
    {
        L t;
        for(int i=0;i<n;i++)
        {
            read(t);
            a[i]=t;
        }
        Merge(0,n-1);
        printf("%lld\n",sum);
        sum=0;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值