A+B for Input-Output Practice (II) java

其实吧,这第二道题感觉也不是我写的啦,在第一道题的时候,百度了,看到有相关的,然后算是抄袭吧,哈哈哈,这第二道题是第一道题的进化版,循序渐进的题,还不错。他们写的也很不错。

题目详情:Your task is to Calculate a + b.
Input:Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line.

Output:For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input:
2
1 5
10 20

Sample Output:
6
30

代码如下:

import java.util.Scanner;  

public class Main {  
    public static void main(String[] args) {  
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        while(n-->0){  
            int a = sc.nextInt();  
            int b = sc.nextInt();  
            System.out.println(a+b);  
        }  
    }  

}  

其实while和for应该是相通的,可以试试for循环,这是我在写这篇文章的时候写的

代码如下:

import java.util.Scanner;  

public class Main {  
    public static void main(String[] args) {  
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
   for(int i=0;i<n;i++){  
            int a = sc.nextInt();  
            int b = sc.nextInt();  
            System.out.println(a+b);  
        }  
    }  

}  

不过是第一段代码的时间比较短,空间也是第一段好。

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值