A+B for Input-Output Practice (V) --JAVA

题目:

Your task is to calculate the sum of some integers. 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 

Sample Input

2
4 1 2 3 4
5 1 2 3 4 5

Sample Output

10
15

题意:

给你一个数字n,代表有n组测试数据,后跟n行,每一行第一个数字是吗,代表后面有m个数字,让你求出来这m个数字的和;

代码如下:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
	Scanner input=new Scanner(System.in);
	int n,m,a,s;
	n=input.nextInt();
	while(true) {
		if(n==0)
			break;
		n--;
		m=input.nextInt();
		s=0;
		for(int i=0;i<m;i++) {
			a=input.nextInt();
			s=s+a;
		}
		System.out.println(s);
	}
}
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值