HD1004-Let the Balloon Rise

Let the Balloon Rise

problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

题解:

我理解的题意就是求出字符串数组中重复出现的字符串,创建一个类存储气球数量和颜色,采用ArrayList<>添加气球颜色,找出出现次数最多的输出。

package HDOJ;

import java.util.Scanner;

public class H1004{
    public static void main(String[] args) throws Exception{
        Scanner cin = new Scanner(System.in);
        while(cin.hasNextInt())
        {
            int num  = cin.nextInt();
            //输入0结束测试
            if(num<=0)
                break;
            //输入测试数据
            List<Item> items = new ArrayList<Item>();
            for(int i = 0;i<num;i++){
                String item = cin.next();
                boolean flag = false;

                for(int j = 0;j<items.size();j++){
                    //集合中包含输入的气球颜色
                    if(items.get(j).str.equals(item)){
                        items.get(j).count+=1;
                        flag = true;
                        break;
                    }
                }
                //集合中不包含输入的气球颜色
                if(!flag){
                    items.add(new Item(item,1));
                }
            }
            //找出出现次数最多的字符串
            int max = items.get(0).count;
            for(int i = 1;i<items.size();i++){
                if(items.get(i).count>max){
                    max = items.get(i).count;
                }
            }
            //输出所有的最多的气球
            for(int i = 0;i<items.size();i++){
                if(items.get(i).count == max){
                    System.out.println(items.get(i).str);
                }

            }
        }

    }
}
class Item{
    public String str;
    public int count;
    public Item(String s,int c){
        str = s;
        count= c;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值