PAT (Advanced Level) 1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题目概述:
给出一颗树的层次遍历,先判断它是不是大根堆或者小根堆,然后再输出其后序遍历。

分析:
1.判断是否是堆,需要将除root节点的所有节点与其父节点进行比较,若全部大于父节点或者全部小于父节点,则可认为为小根堆或者大根堆
2.给出层次遍历,从root开始,先遍历root的左子树,再遍历root的右子树,最后输出root,即可得出后续遍历
3.以上两点基于一个二叉树的通用结论:从root开始从1按层次顺序给树编号,若设当前节点序号为index,左孩子序号为2 * index,右孩子序号为 2 * index + 1,父节点序号为index / 2(index != 0)

#include<bits/stdc++.h>
using namespace std;

int n;
int layer[1010];//全局变量,节点总个数保持不变

void postorder(int index)
{
    if(index > n) return;
    postorder(2 * index);
    postorder(2 * index + 1);
    printf("%d%s", layer[index], index == 1 ? "\n" : " ");
}

int main()
{
    int m;
    cin >> m >> n;
    while(m--)
    {
        int ismax = 1, ismin = 1;
        for(int i = 1; i <= n; i++) scanf("%d",&layer[i]);
        for(int i = 2; i <= n; i++)
        {
            if(layer[i] >= layer[i/2]) ismax = 0;
            if(layer[i] <= layer[i/2]) ismin = 0;
        }
        if(ismax) printf("Max Heap\n");
        else if(ismin) printf("Min Heap\n");
        else printf("Not Heap\n");
        postorder(1);
    }
    return 0;
}


总结
1.熟记binary tree中爸爸和儿子的序号关系
2.熟记binary tree中层次遍历转前、中、后序遍历的写法
3.注意printf中%s要用"",%c要用"

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

白速龙王的回眸

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值