PAT (Advanced Level) 1154 Vertex Coloring (25 分)


各位兄弟们,在肝了一个星期的环境后,我又回来更新一下pat,放松放松身心了!

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10000), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:
4-coloring
No
6-coloring
No

题目概述:
给出一组点集以及其中相连的边的信息,然后给出每个点的染色情况。判断每条边的端点颜色是否都不一样,如果都不一样则输出总颜色数;如果有相同则输出No(这个只用判断,想当年用计算机证明出四色定理是何等威武hhh)

分析:
1.建立edge结构体存储边的信息
2.用vector来记录每个点对应的颜色(从0开始)
3.用set记录不重复的颜色总数
4.逐一判断edge中的起点和终点的颜色是否相同

//同一条边的两个端点颜色不同
//每条边依次判断即可

#include<bits/stdc++.h>
using namespace std;

struct edge
{
    int start;
    int end;
}edgelist[10010];

int main()
{
    int n, m;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < m; i++)
    {
        scanf("%d%d", &edgelist[i].start, &edgelist[i].end);
    }
    int k;
    scanf("%d", &k);
    for(int i = 0; i < k; i++)
    {
        vector<int> color(n);
        set<int> record;
        for(int j = 0; j < n; j++)
        {
            scanf("%d",&color[j]);
            record.insert(color[j]);
        }
        int flag = 1;
        for(int j = 0; j < m; j++)
        {
            if(color[edgelist[j].start] == color[edgelist[j].end])
            {
                flag = 0;
                break;
            }
        }
        if(flag == 0) printf("No\n");
        else
        {
            printf("%d-coloring\n", record.size());
        }
    }
    return 0;
}

总结:
1.这道题不是很难,建立好数据结构就好了
2.一开始调试的时候没注意到有一处scanf写成了printf,debug了好一会。因此,细心行得万年船!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

白速龙王的回眸

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值