1154 Vertex Coloring

题目来源:PAT (Advanced Level) Practice

A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

words:

labeling 标记,标签        graph 图表    

题意:

给出一个无向图和若干组点着色方案,判断每种着色方案是否可行;  

思路:

1. 存储所有的边;

2. 对于每一种着色方案遍历所有的边,若有一条边的两个顶点颜色相同,则该着色方案不可行;

3. 使用set统计每种着色方案种颜色的种类;

 

//PAT ad 1154 Vertex Coloring
#include <iostream>
using namespace std;
#include <vector>
#include <set>

int main()
{
	int n,m,k,i;
	cin>>n>>m;
	
	vector<pair<int,int> > v(m);		//存储边 
	for(i=0;i<m;i++)					//输入边 
		cin>>v[i].first>>v[i].second;
	
	cin>>k;
	while(k--)	
	{
		int color[n];		//存储着色方案 
		set<int> se;		//统计着色方案的颜色个数 
		for(i=0;i<n;i++)	//输入着色方案 
		{
			cin>>color[i];
			se.insert(color[i]);
		}
		for(i=0;i<m;i++)	//判断着色方案是否可行 
			if(color[v[i].first]==color[v[i].second])
				break;
		if(i==m)			//该着色方案可行 
			cout<<se.size()<<"-coloring"<<endl;
		else				//不可行 
			cout<<"No"<<endl;
	}
		
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值