SDUT OJ 1391 : 数据结构上机测试4.1:二叉树的遍历与应用1

Problem Description

输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。

Input

第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。

Output

输出该二叉树的后序遍历序列。

Sample Input

ABDCEF
BDAECF

Sample Output

DBEFCA

Hint

Source

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct node
{
    char data;
    struct node *l, *r;
}NEW;
char xian[55], zhong[55];

NEW *cre(int len,char xian[55],char zhong[55])
{
    NEW *root;
    int i;
    if(len <= 0)return NULL;
    root = (NEW *)malloc(sizeof(NEW));
    root->data = xian[0];
    for(i = 0; i < len; i++)
    {
        if(zhong[i] == xian[0])
            break;
    }
    root->l = cre(i,xian + 1, zhong);
    root->r = cre(len - i - 1, xian + i + 1, zhong  + 1 + i);
    return root;
};
void put_hou(NEW *root)
{
    if(root)
    {
        put_hou(root->l);
        put_hou(root->r);
        printf("%c",root->data);
    }
}
int main()
{
    NEW *root;
    scanf("%s%s",xian,zhong);
    int len = strlen(zhong);
    root = cre(len, xian, zhong);
    put_hou(root);
    printf("\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值