01-复杂度2 Maximum Subsequence Sum(25 分)

01-复杂度2 MaximumSubsequence Sum25 分)

Given a sequence of K integers { N1​, N2​, ..., NK​ }. Acontinuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K.The Maximum Subsequence is the continuous subsequence which has the largest sumof its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, itsmaximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first andthe last numbers of the maximum subsequence.

InputSpecification:

Each input file contains one test case. Each case occupies two lines. Thefirst line contains a positive integer K (≤10000). The second line contains Knumbers, separated by a space.

OutputSpecification:

For each test case, output in one line the largest sum, together with thefirst and the last numbers of the maximum subsequence. The numbers must beseparated by one space, but there must be no extra space at the end of a line.In case that the maximum subsequence is not unique, output the one with thesmallest indices i and j (as shown by the sample case). If all the K numbersare negative, then its maximum sum is defined to be 0, and you are supposed tooutput the first and the last numbers of the whole sequence.

Sample Input:

10

-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目分析:该题目就是最大子列和的一个变形,需要找出最大子列和的开始和结束,还有最大子列和。

经典最大子列和问题:

#include<stdio.h>

#include<stdlib.h>

int  main()

{

    int N;

    scanf("%d",&N);

    int sum=0;

    int number;

    int max_sum=sum;

    while(N--)

    {

       scanf("%d",&number);

        if(sum+number>0)

           sum+=number;

        else

            sum=0;

        if(sum>=max_sum)

            max_sum=sum;

    }

    printf("%d",max_sum);

    return 0;

}

所有问题的分析都是将大问题分解成小问题,然后解决一些细节问题,那么通过经典最大子列和问题,我们可以这样思考,将所有数字存入一个数组,用LeftRight来表示开始和结束,Right的值好确定.只要max_sum更新的时候Right随之更新。

关键在于Left,当sum+array[i]<0时,并且Left需要一个延迟,所以取一个中间变量,Left2

sum+=array[i];

        if(sum<0)

        {

            sum=0;

            Left2=i;

        }

        if(sum>max_sum)

        {

            max_sum=sum;

            Left=Left2+1;

            Right=i;

        }

这样大体思路就有了,现在需要考虑一下Left2的初始值,当数组第一个元素大于零时 Left应该是0,但是Left=Left2+1,所以Left2=-1

还有一个细节问题:关于输出,如果都是负数,输出0array[0],array[N-1]

如果是0和负数相互交错应该输出000

#include<stdio.h>
int main()
{
    int N;
    scanf("%d",&N);
    int array[N];
    int i;
    int Left;
    int flag=0;
    for(i=0;i<N;i++)
    {
        scanf("%d",&array[i]);
        if(array[i]>=0)
            flag=1;
    }//判断是不是都是负数,这样的方式很蠢但是不知道怎么优化
    int Left2=-1;
    int sum=0;
    int max_sum=sum;
    int Right=0;
    for(i=0;i<N;i++)
    {
        sum+=array[i];
        if(sum<0)
        {
            sum=0;
            Left2=i;
        }
        if(sum>max_sum)
        {
            max_sum=sum;
            Left=Left2+1;
            Right=i;
        }
    }
    if(max_sum==0)
    {
        if(!flag)
            printf("%d %d %d",0,array[0],array[N-1]);
        else
            printf("%d %d %d",0,0,0);
    }
    else
       printf("%d %d %d",max_sum,array[Left2],array[Right]);
    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值