02-线性结构3 Reversing Linked List(25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (105) which is the total number of nodes, and a positive K (N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
题目大意:

反转链表,每隔K个链表元素就反转K个链表, 1→2→3→4→5→6, if K=3 , then you must output 3→2→1→6→5→4; if K=4 , you must output 4→3→2→1→5→6.
思路:c++,algorithm中有很多有用的函数,例如reverse函数,反转函数.具体用法可以参考:https://blog.csdn.net/u012877472/article/details/49557077
反转容器的函数, 用于数组需要在数组前加取地符,例如:reverse(&array[i],&array[j])效果是将i到j的数组元素反转。
我们可以用一个数组将链表地址储存起来,按照顺序存起来。然后反转,得到一个反转之后地址的数组。这样在输出。

数据结构设计:用数组模拟,首地址可以用数组下标代替,node中只需要data和next,两个数据类型。
具体代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
typedef struct node
{
 int data;
 int next;
}node;
node array[100000];
int address[100000];
int main()
{
 int N;
 int First;
 int K;
 cin>>First>>N>>K;
 int d;
 for(int i=0;i<N;i++)
 {
  cin>>d;
  cin>>array[d].data>>array[d].next;
 }
 int p=First;
 int cnt=0;
 while(p!=-1)//注意可能有不在链上的多余结点 
 {
  address[cnt++]=p;
  p=array[p].next;
 }
 int i=0;
 while(i+K<=cnt)//同理 
 {
  reverse(&address[i],&address[i+K]);
  i+=K;
 }
 for(i=0;i<cnt-1;i++)//array[address[i]].next不可信,注意 
  printf("%05d %d %05d\n",address[i],array[address[i]].data,address[i+1]);
 printf("%05d %d %d",address[i],array[address[i]].data,-1);
 return 0;
}
代码看不懂,应该用手在纸上写写!
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值