03-树2 List Leaves(25 分)

03-树2 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5
题目大意:从左到右,从上到下,输出其叶子节点。
解题思路:层序遍历,将层序遍历的输出改成判断是叶子节点之后存入容器之中,最后输出,因为输出有格式限制。
#include<iostream>
#include<queue>
#include<vector>
#include<cstring>
#include<string>
using namespace std;
typedef struct tree
{
	int Data;
	int Left;
	int Right;
}tree;
tree T[10];
queue<int>Q;
vector<int>vt;
int Build()
{
	int N;
	cin>>N;
	bool check[N];
	memset(check,false,sizeof(check));
	for(int i=0;i<N;i++)
	{
		char cl,cr;
		cin>>cl>>cr;
		T[i].Data=i;
		if(cl=='-')
		  T[i].Left=-1;
		else
		{
			T[i].Left=cl-'0';
			check[cl-'0']=true;
		}
		if(cr=='-')
		  T[i].Right=-1;
		else
		{
			T[i].Right=cr-'0';
			check[cr-'0']=true;
		}
	}
	int Root;
	int i;
	for(i=0;i<N;i++)
	{
		if(!check[i])
		  break;
	}
	Root=i;
	if(N==0)
	  Root=-1;
	return Root;
}
void Print(int Root)
{
	if(Root==-1)
	  return ;
	Q.push(Root);
	while(!Q.empty())
	{
		int t=Q.front();
		Q.pop();
		if(T[t].Left==-1&&T[t].Right==-1)
		  vt.push_back(T[t].Data);
		//cout<<T[t].Data<<" ";
		if(T[t].Left!=-1) Q.push(T[t].Left);
		if(T[t].Right!=-1) Q.push(T[t].Right);
	}
}
int main()
{
	int Root;
	Root=Build();
	Print(Root);
	vector<int>::iterator p;
	bool flag=false;
	for(p=vt.begin();p!=vt.end();p++)
	{
		if(!flag)
		  cout<<*p;
		else
		  cout<<" "<<*p;
		flag=true;
	}
	return 0;
}

注意,层序遍历的思想:根节点入队,只要队不空,取队首,输出队首对应的数据,队首的左子树,右子树分别入队。循环,这里只要把输出改成,判断叶子节点。
输出格式:最后一个不能有空格

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值