03-树2 List Leaves(25 分)/C

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5
#include <stdio.h>
#include <stdlib.h>

#define MaxTree 10
#define Null -1
typedef char ElementType;
typedef int Tree;
struct TreeNode
{	Tree Left,Right;
}T[MaxTree];

struct Node
{	ElementType Element;
	struct Node* Next;
};

typedef struct QNode* QueueNode;
struct QNode
{	struct Node *Front;
	struct Node *Rear;
};

Tree BuildTree(struct TreeNode T[]);
void SearchLeaves(int Root);
QueueNode CreateQueue(int);//要求从上至下,从左至右 = 层次遍历
QueueNode AddQ(QueueNode,int);//入队
ElementType DeleteQ();//离队

int main()
{
	int Root = BuildTree(T);
	SearchLeaves(Root);
	return 0;
}


Tree BuildTree(struct TreeNode T[])
{
	int n=0,c[MaxTree];
	char tl,tr;
	int i,Root=Null;
	scanf("%d",&n);
	if(n)
	{	
		for (i=0; i<n; i++) c[i] = 0;
		for (i=0; i<n; i++) 
		{
			scanf("\n%c %c",&tl, &tr);
			if (tl != '-') 
			{
				T[i].Left = tl-'0';
				c[T[i].Left] = 1;
			}
			else 
				T[i].Left = Null;
			if (tr != '-')
			{
				T[i].Right = tr - '0';
				c[T[i].Right] = 1;
			}
			else
				T[i].Right = Null;
		}
		for(i=0;i<n;i++)
			if(!c[i]) break;
		Root = i;
	}
	return Root;
}

QueueNode CreateQueue()
{
	QueueNode PtrQ = (QueueNode)malloc(sizeof(struct QNode));
	PtrQ->Front = PtrQ->Rear = NULL;
	return PtrQ;
}

QueueNode AddQ(QueueNode Q,int X)
{
	struct Node* temp = (struct Node*)malloc(sizeof(struct Node));
	temp->Element = X;
	temp->Next = NULL;
	if(Q->Front == NULL)
	{
		Q->Front = temp;
		Q->Rear = Q->Front;
	}
	else
	{
		Q->Rear->Next = temp;
		Q->Rear = temp;
	}
	return Q;
}
ElementType DeleteQ(QueueNode Q)
{
	struct Node* temp;
	int X;
	if(Q->Front == NULL)
		return Null;
	temp = Q->Front;
	X = Q->Front->Element;
	if(Q->Front == Q->Rear)
		Q->Front = Q->Rear = NULL;
	else
		Q->Front = Q->Front->Next;
	free(temp);
	return X;
}

void SearchLeaves(int Root)//层次遍历
{
	int flag = 0;
	QueueNode Q = CreateQueue();
	AddQ(Q, Root);//加入根节点
	while (Q->Front)//扫描树
	{
		Root = DeleteQ(Q);
		if(T[Root].Left == Null && T[Root].Right == Null)
		{
			if(flag) printf(" %d",Root);
			else 
			{
			        printf("%d",Root);
			        flag = 1;
			}
		}
		else if(T[Root].Left !=Null && T[Root].Right == Null)
			AddQ(Q,T[Root].Left);
		else if(T[Root].Left ==Null && T[Root].Right != Null)
			AddQ(Q,T[Root].Right);
		else
		{	
			AddQ(Q,T[Root].Left);
			AddQ(Q,T[Root].Right);
		}
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值