poj2356

Find a multiple

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source

鸽巢原理。对于给定的序列a1,a2,a3,...an,存在一个连续子序列ai~aj,使得其和整除n。与poj3370几乎完全相同。
代码如下:
#include<stdio.h>
#include<string.h>

int main(void) {
    int number[10001];
    int left[10001];
    int rem;
    int n;
    int start;
    int end;
    while (scanf("%d", &n) != -1) {
        memset(left, 0, sizeof (left));
        rem = 0;
        for (int i = 1; i <= n; i++)
            scanf("%d", &number[i]);
        for (int i = 1; i <= n; i++) {
            rem = (rem + number[i]) % n;
            if (rem == 0) {
                start = 1;
                end = i;
                break;
            }
            if (left[rem]) {
                start = left[rem] + 1;
                end = i;
                break;
            }
            left[rem] = i;
        }
        printf("%d\n", end - start + 1);
        for (int i = start; i <= end; i++)
            printf("%d\n", number[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值