相似三角形
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
给出两个三角形的三条边,判断是否相似。
Input
多组数据,给出6正个整数,a1,b1,c1,a2,b2,c2,分别代表两个三角形。(边长小于100且无序)
Output
如果相似输出YES,如果不相似输出NO,如果三边组不成三角形也输出NO。
Example Input
1 2 3 2 4 6 3 4 5 6 8 10 3 4 5 7 8 10
Example Output
NO YES NO
Hint
Author
#include<stdio.h>
int main()
{
int a1,b1,c1,a2,b2,c2,t;
while(scanf("%d %d %d %d %d %d",&a1,&b1,&c1,&a2,&b2,&c2)!=EOF)
{
if(a1>b1) {t=a1;a1=b1;b1=t;}
if(a1>c1) {t=a1;a1=c1;c1=t;}
if(b1>c1) {t=b1;b1=c1;c1=t;}
if(a2>b2) {t=a2;a2=b2;b2=t;}
if(a2>c2) {t=a2;a2=c2;c2=t;}
if(b2>c2) {t=b2;b2=c2;c2=t;}
if((a1+b1>c1)&&(a2+b2>c2))
{
if (a1*1.0/a2==b1*1.0/b2&&b1*1.0/b2==c1*1.0/c2) printf("YES\n");
else printf("NO\n");
}
else printf("NO\n");
int main()
{
int a1,b1,c1,a2,b2,c2,t;
while(scanf("%d %d %d %d %d %d",&a1,&b1,&c1,&a2,&b2,&c2)!=EOF)
{
if(a1>b1) {t=a1;a1=b1;b1=t;}
if(a1>c1) {t=a1;a1=c1;c1=t;}
if(b1>c1) {t=b1;b1=c1;c1=t;}
if(a2>b2) {t=a2;a2=b2;b2=t;}
if(a2>c2) {t=a2;a2=c2;c2=t;}
if(b2>c2) {t=b2;b2=c2;c2=t;}
if((a1+b1>c1)&&(a2+b2>c2))
{
if (a1*1.0/a2==b1*1.0/b2&&b1*1.0/b2==c1*1.0/c2) printf("YES\n");
else printf("NO\n");
}
else printf("NO\n");
}
return 0;
}
return 0;
}