java相似三角形

Problem Description

给出两个三角形的三条边,判断是否相似。

Input

多组数据,给出6正个整数,a1,b1,c1,a2,b2,c2,分别代表两个三角形。(边长小于100且无序

Output

如果相似输出YES,如果不相似输出NO,如果三边组不成三角形也输出NO。

Example Input
1 2 3 2 4 6
3 4 5 6 8 10
3 4 5 7 8 10
Example Output
NO
YES
NO
import java.util.Scanner;
public class Main 
{
 public static void main(String[] args) 
 {
  Scanner reader=new Scanner(System.in);
  while(reader.hasNext())
  {
   int a1,a2,b1,b2,c1,c2;
         a1=reader.nextInt();
         b1=reader.nextInt();
         c1=reader.nextInt();
         a2=reader.nextInt();
         b2=reader.nextInt();
         c2=reader.nextInt();
         int t;
         if(a1<b1)
         {
          t=a1;a1=b1;b1=t;          
         }
         if(a1<c1)
         {
          t=a1;a1=c1;c1=t;          
         }
         if(b1<c1)
         {
          t=b1;b1=c1;c1=t;          
         }
         if(a2<b2)
         {
          t=a2;a2=b2;b2=t;          
         }
         if(a2<c2)
         {
          t=a2;a2=c2;c2=t;          
         }
         if(b2<c2)
         {
          t=b2;b2=c2;c2=t;          
         }
         if((c1+b1>a1) && (c2+b2>a2))
         {
          if((a1*b2==b1*a2) && (a1*c2==c1*a2) && (b1*c2==c1*b2))
          {
           System.out.println("YES");
          }
          else
          {
           System.out.println("NO");
          }
         }
         else
         {
          System.out.println("NO");
         }
  }    
 }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值