To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading
and being
are stored as showed in Figure 1.
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i
in Figure 1).
Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next
whereAddress
is the position of the node, Data
is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next
is the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1
instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
思路:按照给出的两个初始地址和链表顺序依次将各地址放入两个数组中,再将两个数组从后往前依次比较,直到出现对应位置的地址不一样,输出后一个地址即可。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
//freopen("1.txt","r",stdin);
//寻找是否有公共后缀
int Next[100010], list1[100010], list2[100010];
char Data[100010];
int first1, first2, n;
cin>>first1 >>first2 >> n;
int temp;
for(int i = 0; i < n; i++) {
cin>>temp;
cin>>Data[temp] >> Next[temp];
}
int sum1 = 0, sum2 = 0;
while(first1 != -1) {
list1[sum1++] = first1;
first1 = Next[first1];
}
list1[sum1] = -1;
while(first2 != -1) {
list2[sum2++] = first2;
first2 = Next[first2];
}
list2[sum2] = -1;
int en1 = sum1, en2 = sum2;
while(en1 > -1 && en2 > -1 && list1[en1] == list2[en2]) {
--en1;
--en2;
}
if(list1[en1 + 1] == -1) printf("-1\n");
else printf("%05d\n",list1[en1 + 1]);
return 0;
}