PAT 甲级 1032 Sharing

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

 题意:

        第一行分别给出两个链表的头节点,和节点个数,后面给出n个节点的地址,数据与和next域,找出两个链表的第一个公共节点,并输出其地址;

思路:

        第一步:先建立节点,第二步:再遍历第一条链表,把第一条链表的节点标记,然后遍历第二条链表,如果第二条链表的节点有被标记就输出该节点的地址;

  代码:

#include<cstring>
#include<cstdio>
const int Maxn = 1e5 + 10;

struct Node {
	char data;
	int next = -1;//结构体内初始化是有效的; 
	bool flag = false;
}node[Maxn];

int main() {
	int head1, head2, n, add, next;
	char data;
	scanf("%d %d %d", &head1, &head2, &n);
	for(int i = 0; i < n; i++) {
		scanf("%d %c %d", &add, &data, &next);
		node[add].data = data;
		node[add].next = next;
	}
	add = head1;
	while(add != -1) {
		node[add].flag = true;
		add = node[add].next;
	}
	add = head2;
	while(add != -1) {
		if(node[add].flag == true) {
			break; 
		} else {
			add = node[add].next;
		}
	}
	add == -1 ? printf("-1") : printf("%05d", add);
	return 0;
}

        

总结:

链表分为静态链表和动态链表

区别:
静态链表:

结构体作结点,数组存储链表,结点内的next域是整型数,而不是指针,因为他存储的是下一个结点的下标(即地址)

缺点:当结点地址较小的时候可用,如5位数的地址;

动态链表:
结构体作结点,结点内的next域是node 指针

缺点:较复杂

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值