Round Numbers(poj-3252,二进制数位dp)

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive rangeStart.. Finish

Sample Input

2 12

Sample Output

6

题意:

问a~b之间有多少个数的二进制下0的个数大于等于1的个数

解析:

这题要注意如果第一位放下0,则是无效的,前导0是无效的,只有第一位为1,这个二进制才开始

所以要记录是否已经开始二进制了

ac:

#include<cstdio>
#include<cstring>
#include <algorithm>
using namespace std;

int dp[50][50][50],bit[50];//dp[k][i][j],k为位数,i为0的个数,j为1的个数

int dfs(int pos,int num0,int num1,int work,int first)
{       //first是标记是否未放下
    if(!pos)
        return num0>=num1;
    if(!first && !work && dp[pos][num0][num1]!=-1)
        return dp[pos][num0][num1];
    int end = work?bit[pos]:1;//判断此位能否为1
    int ans = 0;
    for(int i = 0; i<=end; i++)
    {
        if(first)//有前导0,放0无效,放1则开始二进制
        {
            if(i)
                ans+=dfs(pos-1,num0,num1+1,work&&end==i,0);//放1,从这里二进制开始
            else
                ans+=dfs(pos-1,0,0,work&&end==i,1);//放0,但是这个0无效,所以往下看
        }
        else
        {
            if(i)
                ans+=dfs(pos-1,num0,num1+1,work&&end==i,0);//放1
            else
                ans+=dfs(pos-1,num0+1,num1,work&&end==i,0);//放0
        }
    }
    if(!work && !first)
        dp[pos][num0][num1] = ans;
    return ans;
}

int solve(int n)
{
    int len = 1;
    while(n)
    {
        bit[len++] = n%2;
        n>>=1;
    }
    int ans = dfs(len-1,0,0,1,1);
    return ans;
}

int main()
{
    memset(dp,-1,sizeof(dp));
    int l,r;
    while(scanf("%d%d",&l,&r)!=EOF)
    {
        printf("%d\n",solve(r)-solve(l-1));
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值