最短路Floyd及输出路径 HDU 1385

Problem Description

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

 

 

Input

First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

 

 

Output

From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.
 

 

 

Sample Input

 

5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0

 

 

Sample Output

 

From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1385

题目大意:有N个城市,然后直接给出这些城市之间的邻接矩阵,矩阵中-1代表那两个城市无道路相连,其他值代表路径长度。 如果一辆汽车经过某个城市,必须要交一定的钱(可能是过路费)。 现在要从a城到b城,花费为路径长度之和,再加上除起点与终点外所有城市的过路费之和。 求最小花费,如果有多条路经符合,则输出字典序最小的路径。

 

运用Floyd算法求出每两点的最短路径即可。 对应输出路径。

 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std ;
const int maxn = 500 + 10 ;
const int inf = 0x3f3f3f3f ;

int Map[maxn][maxn], pa[maxn][maxn] ;
int tax[maxn] ;

int main (){
    int n ;
    while (~scanf("%d", &n) && n){
        for (int i = 1; i <= n; i++){
            for (int j = 1; j <= n; j++){
                scanf("%d", &Map[i][j]) ;
                if (Map[i][j] == -1){
                    Map[i][j] = inf ;
                }
                pa[i][j] = j ;
            }
        }
        for (int i = 1; i <= n; i++){
            scanf("%d", &tax[i]) ;
        }
        for (int k = 1; k <= n; k++){
            for (int i = 1; i <= n; i++){
                for (int j = 1; j <= n; j++){
                    if (Map[i][j] > Map[i][k] + Map[k][j] + tax[k]){
                        Map[i][j] = Map[i][k] + Map[k][j] + tax[k] ;
                        pa[i][j] = pa[i][k] ;
                    }
                    else {
                        if (Map[i][j] == Map[i][k] + Map[k][j] + tax[k] && pa[i][j] > pa[i][k]){
                            pa[i][j] = pa[i][k] ;
                        }
                    }
                }
            }
        }
        int a, b;
        while (scanf("%d%d", &a, &b) && (a != -1 || b != -1)){
            printf("From %d to %d :\nPath: %d", a, b, a);
            int u = a, v = b;
            while (u != v){
                printf("-->%d", pa[u][v]);
                u = pa[u][v];
            }
            printf("\nTotal cost : %d\n\n", Map[a][b]);
        }
    }
    return 0 ;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
最短路问题是计算从起点到终点的最短路径的问题,常见的算法有Dijkstra算法和Floyd算法。下面给出Dijkstra算法的C语言代码及输出路径的实现。 先定义一个图结构体,包括顶点数、边数、邻接矩阵、起点和终点等信息: ```c #define MAX_VERTEX_NUM 100 // 最大顶点数 #define INF 0x3f3f3f3f // 表示无穷大 typedef struct { int vexNum; // 顶点数 int arcNum; // 边数 int arcs[MAX_VERTEX_NUM][MAX_VERTEX_NUM]; // 邻接矩阵 int start; // 起点 int end; // 终点 } Graph; ``` 然后是Dijkstra算法的实现: ```c void Dijkstra(Graph g, int *dist, int *path) { bool visited[MAX_VERTEX_NUM] = { false }; // 标记数组,表示是否访问过 for (int i = 0; i < g.vexNum; i++) { dist[i] = g.arcs[g.start][i]; // 初始化距离数组 path[i] = -1; // 初始化路径数组 } visited[g.start] = true; // 起点已访问 dist[g.start] = 0; // 起点到自身的距离为0 for (int i = 1; i < g.vexNum; i++) { // 循环n-1次 int minDist = INF; int u = g.start; for (int j = 0; j < g.vexNum; j++) { if (!visited[j] && dist[j] < minDist) { // 找到未访问过的距离最短的顶点 minDist = dist[j]; u = j; } } visited[u] = true; // 标记为已访问 for (int v = 0; v < g.vexNum; v++) { if (!visited[v] && g.arcs[u][v] != INF && dist[u] + g.arcs[u][v] < dist[v]) { // 更新距离和路径 dist[v] = dist[u] + g.arcs[u][v]; path[v] = u; } } } } ``` 最后是输出路径的实现: ```c void PrintPath(Graph g, int *path) { int stack[MAX_VERTEX_NUM], top = 0; int p = g.end; while (p != -1) { // 将路径上的顶点压入栈中 stack[top++] = p; p = path[p]; } printf("The shortest path from %d to %d is: ", g.start, g.end); while (top > 1) { // 逆序输出路径上的顶点 printf("%d -> ", stack[--top]); } printf("%d\n", stack[--top]); } ``` 完整代码如下: ```c #include <stdio.h> #include <stdbool.h> #define MAX_VERTEX_NUM 100 // 最大顶点数 #define INF 0x3f3f3f3f // 表示无穷大 typedef struct { int vexNum; // 顶点数 int arcNum; // 边数 int arcs[MAX_VERTEX_NUM][MAX_VERTEX_NUM]; // 邻接矩阵 int start; // 起点 int end; // 终点 } Graph; void Dijkstra(Graph g, int *dist, int *path) { bool visited[MAX_VERTEX_NUM] = { false }; // 标记数组,表示是否访问过 for (int i = 0; i < g.vexNum; i++) { dist[i] = g.arcs[g.start][i]; // 初始化距离数组 path[i] = -1; // 初始化路径数组 } visited[g.start] = true; // 起点已访问 dist[g.start] = 0; // 起点到自身的距离为0 for (int i = 1; i < g.vexNum; i++) { // 循环n-1次 int minDist = INF; int u = g.start; for (int j = 0; j < g.vexNum; j++) { if (!visited[j] && dist[j] < minDist) { // 找到未访问过的距离最短的顶点 minDist = dist[j]; u = j; } } visited[u] = true; // 标记为已访问 for (int v = 0; v < g.vexNum; v++) { if (!visited[v] && g.arcs[u][v] != INF && dist[u] + g.arcs[u][v] < dist[v]) { // 更新距离和路径 dist[v] = dist[u] + g.arcs[u][v]; path[v] = u; } } } } void PrintPath(Graph g, int *path) { int stack[MAX_VERTEX_NUM], top = 0; int p = g.end; while (p != -1) { // 将路径上的顶点压入栈中 stack[top++] = p; p = path[p]; } printf("The shortest path from %d to %d is: ", g.start, g.end); while (top > 1) { // 逆序输出路径上的顶点 printf("%d -> ", stack[--top]); } printf("%d\n", stack[--top]); } int main() { Graph g; scanf("%d %d %d %d", &g.vexNum, &g.arcNum, &g.start, &g.end); for (int i = 0; i < g.vexNum; i++) { for (int j = 0; j < g.vexNum; j++) { g.arcs[i][j] = INF; } } for (int i = 0; i < g.arcNum; i++) { int u, v, w; scanf("%d %d %d", &u, &v, &w); g.arcs[u][v] = w; g.arcs[v][u] = w; // 无向图 } int dist[MAX_VERTEX_NUM], path[MAX_VERTEX_NUM]; Dijkstra(g, dist, path); printf("The shortest distance from %d to %d is: %d\n", g.start, g.end, dist[g.end]); PrintPath(g, path); return 0; } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值