Browserslist: caniuse-lite is outdated. Please run next command `npm update`

今天打包vue项目,突然蹦出一个告警:

Browserslist: caniuse-lite is outdated. Please run next command `npm update`

按照提示操作,运行npm update也没有解决。

于是我查询了一下npm手册,得知是不能直接运行npm update的,必须带上包名,所以应该这样写命令:

npm update caniuse-lite

或者直接删了node_modules/caniuse-lite文件夹,然后重新安装:

npm i -g caniuse-lite

这样问题就解决了!


如果还不行,试试这个步骤。

  1. 先删了node_modules/caniuse-lite和node_modules/browserslist两个文件夹

  2. 然后运行下面的命令

npm i --save-dev caniuse-lite browserslist
评论 8 您还未登录,请先 登录 后发表或查看评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:技术黑板 设计师:CSDN官方博客 返回首页

打赏作者

前端司南

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值