PAT1009 Product of Polynomials (25 分)

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N 1   a N 1   N 2   a N 2   . . .   N K   a N K N_1\ a_{N_1}\ N_2\ a_{N2}\ ...\ N_K\ a_{N_K} N1 aN1 N2 aN2 ... NK aNK
where K is the number of nonzero terms in the polynomial, N ​ i N​_i Ni and a N i a_{N_i} aNi
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 1≤K≤10 1K10, 0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000 0≤N_K<⋯<N_2<N_1≤1000 0NK<<N2<N11000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6




解析

这题要注意的是:多项式相乘后:有的项的系数可能为0.注意筛选。
多项式相乘:用双重循环相乘后,生成的多项式:可能指数不是按从大到小排序的。
比如说:
polynomial1 x 3 + x 1 x^3+x^1 x3+x1
polynomial2 x 100 + x 1 x^{100}+x^{1} x100+x1
polynomial x 103 + x 4 + x 101 + x 2 x^{103}+x^{4}+x^{101}+x^{2} x103+x4+x101+x2
无论用什么数据结构:都要注意这上面的两点哟。



Code:

#include <stdio.h>
double polynomial[2020];
double temp[1010];
int main()
{
    int k, exp;
    double coe;
    scanf("%d", &k);
    while ( k-- ){
        scanf("%d %lf", &exp, &coe);
        temp[exp] = coe;
    }
    scanf("%d", &k);
    while ( k-- ){
        scanf("%d %lf", &exp, &coe);
        for(int i=0; i<1010; i++)
            if(temp[i] != 0.0)
                polynomial[i+exp] += coe*temp[i];
    }
    int count = 0;
    for( int i=0; i<2020; i++)
        if ( polynomial[i] != 0.0)
            ++count;
    printf("%d", count);
    for( int i=2019; i>=0; i--)
        if ( polynomial[i] != 0.0)
            printf(" %d %.1f", i, polynomial[i]);
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值