PAT 1009(简单模拟)

1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

一、试题分析:

  • 本题和1002思路类似:都是多项式的计算
  • 区别在于:
  1. 1002为多项式加法:只需循环要输入第二行时直接相加即可
  2. 本题为多项式乘法:在循环输入第二行的时候循环与第一个多项式每一项相乘,结果保存到另一个数组(比原数组大小大一倍)

二、解题要点:

  • 多项式项与项相乘后,指数会变大:结果数组大小要扩大一倍
  • 循环输入第二个多项式时:每一项要与第一个多项式每一项相乘,相乘后不为0(a[]数组系数不为0),结果才存储到结果数组中
  • 最后输出结果要保留一位小数:
  1. #include <iomanip>
  2. <<setiosflags(ios::fixed)
  3. <<setprecision(1)
#include <iostream>
#include <iomanip>
using namespace std;

int main()
{
    int k1,k2;
    double a[1001]={0};
    double b[1001]={0};
    double res[2001]={0};
    int exp;
    double coe;
    int count=0;
    cin>>k1;
    for(int i=0;i<k1;i++){
        cin>>exp>>coe;
        a[exp]=coe;
    }
    cin>>k2;
    for(int i=0;i<k2;i++){
        cin>>exp;
        cin>>b[exp];
        for(int j=0;j<1001;j++){ //每一项要与第一个多项式每一项相乘
            if(a[j]!=0){
                res[exp+j]+=(a[j]*b[exp]); //结果存储到结果数组中
            }
        }
    }
    for(int i=0;i<2001;i++){
        if(res[i]!=0)
            count++;
    }
    cout<<count;
    for(int i=2000;i>=0;i--){
        if(res[i]!=0){
            cout<<' '<<i<<' '<<setiosflags(ios::fixed)<<setprecision(1)<<res[i]; //最后输出结果要保留一位小数
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值