1015 Reversible Primes (20分) 素数转换

1015 Reversible Primes (20分)

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<10
​5
​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

心得

这个题很简单 当学单词了reversible 翻转,prime素数 radix 进制。

错误

这个题,最开始一直没跑过去,是因为0 1 不是质数,需要注意一下,这个没有考虑进去

#include <iostream>
#include <string>
using namespace std;

int getRadixNumber(int M, int D) {
	string word;
	int num=0;
	while (M!=0)
	{	
		word += to_string(M%D);
		M /= D;
	}
	for (int i = 0; i < word.length(); i++)
	{
		num = num * D + (word[i] - '0');
	}
	return num;
}

bool isPrime(int number) {
	for (int  i = 2; i < number; i++)
	{
		if (number%i == 0) return false;
	}
	if (number == 0 || number == 1)return false;
	return true;
}
int main() {
	while (true)
	{
		int N, D;
		cin >> N;
		if (N < 0)break;
		cin >> D;

		int num = getRadixNumber(N, D);
		if (isPrime(N) && isPrime(num)) cout << "Yes\n";
		else cout << "No\n";
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值