P1443 马的遍历

题目描述
有一个n*m的棋盘(1<n,m<=400),在某个点上有一个马,要求你计算出马到达棋盘上任意一个点最少要走几步


输入输出格式
输入格式:
一行四个数据,棋盘的大小和马的坐标


输出格式:
一个n*m的矩阵,代表马到达某个点最少要走几步(左对齐,宽5格,不能到达则输出-1)


输入输出样例
输入样例#1: 
3 3 1 1
输出样例#1: 
0    3    2    
3    -1   1    

2    1    4    


#include<stdio.h>
int xx[8] = {-2,-1,1,2,2,1,-1,-2};
int yy[8] = {1,2,2,1,-1,-2,-2,-1};
int n,m,head,tail;
int arr[410][410];
int book[410][410];
int ans[410][410];
struct note{
	int r;
	int c;
	int sum;
};
struct note que[160050];

int main(){
	int startx,starty;
	scanf("%d%d%d%d",&n,&m,&startx,&starty);
	for(int i = 1;i <= n;i ++){
		for(int j = 1;j <= m;j ++){
			ans[i][j] = -1;
		}
	}
	head = 1;
	tail = 1;
	que[tail].r = startx;
	que[tail].c = starty;
	que[tail].sum = 0;
	tail++;
	ans[startx][starty] = 0;
	book[startx][starty] = 1;
	
	while(head<tail){
		for(int i = 0;i < 8;i ++){
			int tx = que[head].r + xx[i];
			int ty = que[head].c + yy[i];
			if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&book[tx][ty] == 0){
				book[tx][ty] = 1;
				que[tail].r = tx;
				que[tail].c = ty;
				que[tail].sum = que[head].sum+1;
				ans[tx][ty] = que[tail].sum;
				tail++;
				
			}
		}
		head++;
	}
	for(int i = 1;i <= n;i ++){
		for(int j = 1;j <= m;j ++){
			printf("%-5d",ans[i][j]);
		}
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值