浙大《数据结构》09-排序3 Insertion or Heap Sort

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 100 ) N (≤100) N(100). Then in the next line, N N N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N N N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9

此题基本上和上一题差不多。核心的部分就是堆操作中的PercDown下滤操作,可参考mooc视频。
完整代码:

#include<iostream>
#include<queue>
using namespace std;

void printA(int A[], int N) {
	for (int i = 0; i < N; i++) {
		printf("%d", A[i]);
		if (i != N - 1)printf(" ");
		else printf("\n");
	}
}

int main() {
	int N = 0;
	cin >> N;
	int *A = (int *)malloc(N * sizeof(int));
	for (int i = 0; i < N; i++)
		cin >> A[i];
	int *partial_A = (int *)malloc(N * sizeof(int));
	for (int i = 0; i < N; i++)
		cin >> partial_A[i];
	//判断是否是插入排序,否则为归并排序
	int j = 0;
	while (partial_A[j] <= partial_A[j + 1])
		j++;
	int index = j + 1; //记录
	while (partial_A[++j] == A[j])
		if (j == N - 1)break;
	if (j == N - 1) {//即从第一个逆序发生后,后面和A一样
		printf("Insertion Sort\n");
		int temp = partial_A[index];
		int i = 0;
		for (i = index; i > 0 && partial_A[i - 1] > temp; i--)
			partial_A[i] = partial_A[i - 1];
		partial_A[i] = temp;
	}
	else {
		printf("Heap Sort\n");
		int i = 0;
		for ( ; i < N; i++)
			if (partial_A[i] > partial_A[0]) break;
		i = i - 1; //i此时指向堆的最后一个元素
		//交换堆的第一个元素和最后一个元素
		int temp = partial_A[0];
		partial_A[0] = partial_A[i];
		partial_A[i] = temp;
		int size = i; //此时堆的元素个数
		//调整堆
		int X = partial_A[0];
		int Parent = 0;
		int Child;
		for (Parent = 0; Parent * 2 + 1 < size; Parent = Child) {
			Child = Parent * 2 + 1;
			if ((Child + 1 < size) && (partial_A[Child] < partial_A[Child + 1]))
				Child++;  /* Child指向左右子结点的较大者 */
			if (X >= partial_A[Child]) break; /* 找到了合适位置 */
			else  /* 下滤X */
				partial_A[Parent] = partial_A[Child];
		}
		partial_A[Parent] = X;
	}
	printA(partial_A, N);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值