09-排序3 Insertion or Heap Sort (25分) (2020浙大Mooc数据结构配套题)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

  和排序2是一样的操作,不过把归并排序变成了堆排序

示例代码:

#include<stdio.h>
#include<stdlib.h>

typedef long ElementType;
 
int Insertion_Sort(ElementType A[], int N);
int Indicate();
void Heap_Sort(ElementType A[],int N);
void Reset();

ElementType Origin[100];
ElementType Check[100];
ElementType temp[100];
int N;


int main()
{
	int i;
	scanf("%d",&N);
	for(i = 0; i < N; i++){
		scanf("%d",&Origin[i]);
	}
	for(i = 0; i < N; i++){
		scanf("%d",&Check[i]);
	}
	Reset();
	if(!Insertion_Sort(temp,N)){
		return 0;
	}
//	Insertion_Sort(temp,N);
	Reset();
	Heap_Sort(temp,N);
	
} 

void Reset(){
	int i;
	for(i = 0; i < N; i++){
		temp[i] = Origin[i];
	}
}

//一遍遍检测发现不一样就返回0 
int Indicate()
{
	int i;
	for(i = 0; i < N; i++){
		if(temp[i] != Check[i]){
			return 0;
		}
	}
	return 1;
}

void PrintNum(){
	int i;
	for(i = 0; i < N; i++){
		if(i == 0){
			printf("%d",temp[i]);
		}else{
			printf(" %d",temp[i]);
		}
	}
}

//插入排序,O(n^2),稳定 
int Insertion_Sort(ElementType A[], int N)
{
	int i,j;
	ElementType temp;
	for(i = 1; i < N; i++){
		temp = A[i];//保存要比较的元素 
		for(j = i - 1; j >= 0 && A[j] > temp; j--)//当temp是比前一个元素小的时候,前面的元素往后移位 
			A[j + 1] = A[j]; 
		A[j + 1] = temp;
            
		if( Indicate() ){
			printf("Insertion Sort\n");
			i++;
			temp = A[i];//保存要比较的元素 
			for(j = i - 1; j >= 0 && A[j] > temp; j--){//当temp是比前一个元素小的时候,前面的元素往后移位 
				A[j + 1] = A[j]; 
			}
			A[j + 1] = temp;
			PrintNum();
			return 0;
		}
		
	} 
	return 1;
}

void PercDown( ElementType A[], int p, int N )
{
	int Parent,Child;
	ElementType temp = A[p];
	for(Parent = p; (Parent * 2 + 1) < N; Parent = Child){
		Child = Parent * 2 + 1;
		if(Child + 1 != N && A[Child + 1] > A[Child]){
			Child++;
		}
		if(temp >= A[Child])
			break;
		else
			A[Parent] = A[Child];
	}
	A[Parent] = temp;
}

void Swap(ElementType *a,ElementType *b){
	ElementType c;
	c = *a;
	*a = *b;
	*b = c;
}

//堆排序,挺快 
void Heap_Sort(ElementType A[],int N)
{
	int i;
	for(i = N / 2 - 1; i >= 0; i--){
		PercDown(A,i,N);
	}
	for(i = N - 1; i > 0; i--){
		if(!Indicate()){
			Swap(&A[0],&A[i]);
			PercDown(A,0,i);
		}else{
			Swap(&A[0],&A[i]);
			PercDown(A,0,i);
			printf("Heap Sort\n");
			PrintNum();
			return;
		}
		
	} 
 } 
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值