A Question of Ingestion

题目描述

Stan Ford is a typical college graduate student, meaning that one of the most important things on his mind is where his next meal will be. Fortune has smiled on him as he’s been invited to a multi-course barbecue put on by some of the corporate sponsors of his research team, where each course lasts exactly one hour.Stan is a bit of an analytical type and has determined that his eating pattern over a set of consecutive hours is always very consistent. In the first hour, he can eat up to m calories (where m depends on factors such as stress, bio-rhythms, position of the planets, etc.), but that amount goes down by a factor of two-thirds each consecutive hour afterwards (always truncating in cases of fractions of a calorie). However, if he stops eating for one hour, the next hour he can eat at the same rate as he did before he stopped. So, for example, if m = 900 and he ate for five consecutive hours, the most he could eat each of those hours would be 900, 600, 400, 266 and 177 calories, respectively. If, however, he didn’t eat in the third hour, he could then eat 900, 600, 0, 600 and 400 calories in each of those hours. Furthermore, if Stan can refrain from eating for two hours, then the hour after that he’s capable of eating m calories again. In the example above, if Stan didn’t eat during the third and fourth hours, then he could consume 900, 600, 0, 0 and 900 calories.

Stan is waiting to hear what will be served each hour of the barbecue as he realizes that the menu will determine when and how often he should refrain from eating. For example, if the barbecue lasts 5 hours and the courses served each hour have calories 800, 700, 400, 300, 200 then the best strategy when m = 900 is to eat every hour for a total consumption of 800 + 600 + 400 + 266 + 177 = 2 243 calories. If however, the third course is reduced from 400 calories to 40 calories (some low-calorie celery dish), then the best strategy is to not eat during the third hour — this results in a total consumption of 1 900 calories. The prospect of all this upcoming food has got Stan so frazzled he can’t think straight. Given the number of courses and the number of calories for each course, can you determine the maximum amount of calories Stan can eat?

 

输入

Input starts with a line containing two positive integers n m (n ≤ 100, m ≤ 20 000) indicating the number of courses and the number of calories Stan can eat in the first hour, respectively. The next line contains n positive integers indicating the number of calories for each course.

 

输出

Display the maximum number of calories Stan can consume.

 

样例输入

5 900
800 700 400 300 200

 

样例输出

2243
#include <bits/stdc++.h>
using namespace std;
int dp[105][105][2];
int main()
{
    int n,maxp;
    scanf("%d%d",&n,&maxp);
    int a[105];
    for(int i=1; i<=n; i++)
        scanf("%d",&a[i]);
    int ap[105];
    ap[1] = maxp;
    for(int i=2; i<=n; i++)
        ap[i] = ap[i-1]*2/3;
//    dp[1][1][1] = a[1]>ap[1]?ap[1]:a[1];
//    dp[1][0][0] = 0;
    for(int i=1; i<=n; i++)
    {
        dp[i][1][1]=min(a[i],ap[1]);
        if(i>2)
        {
            for(int j=0;j<=i-3;j++)
            {
                dp[i][1][1]=max(dp[i][1][1],dp[i-3][j][1]+min(a[i],ap[1]));
                dp[i][1][1]=max(dp[i][1][1],dp[i-3][j][0]+min(a[i],ap[1]));
            }
        }
        if(i>1)
        {
            for(int j=0; j<=i-2; j++)
            {
                dp[i][0][0]=max(dp[i][0][0],dp[i-2][j][0]);
                dp[i][0][0]=max(dp[i][0][0],dp[i-2][j][1]);
            }
        }
        for(int j=1; j<=i; j++)
        {
            dp[i][j][1]=max(dp[i][j][1],dp[i-1][j-1][1]+min(a[i],ap[j]));
            dp[i][j][1]=max(dp[i][j][1],dp[i-1][j][1]);
            if(i>1)
            {
                dp[i][j][1]=max(dp[i][j][1],dp[i-2][j][1]+min(a[i],ap[j]));
            }
        }
    }
    int ans=0;
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=i; j++)
        {
            for(int k=0; k<2; k++)
            {
                ans=max(ans,dp[i][j][k]);
            }
        }
    }
    printf("%d\n",ans);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值