POJ - 3974(Manacher算法)

Andy the smart computer science student was attending an algorithms class when the professor asked the students a simple question, "Can you propose an efficient algorithm to find the length of the largest palindrome in a string?"

A string is said to be a palindrome if it reads the same both forwards and backwards, for example "madam" is a palindrome while "acm" is not.

The students recognized that this is a classical problem but couldn't come up with a solution better than iterating over all substrings and checking whether they are palindrome or not, obviously this algorithm is not efficient at all, after a while Andy raised his hand and said "Okay, I've a better algorithm" and before he starts to explain his idea he stopped for a moment and then said "Well, I've an even better algorithm!".

If you think you know Andy's final solution then prove it! Given a string of at most 1000000 characters find and print the length of the largest palindrome inside this string.
Input
Your program will be tested on at most 30 test cases, each test case is given as a string of at most 1000000 lowercase characters on a line by itself. The input is terminated by a line that starts with the string "END" (quotes for clarity).
Output
For each test case in the input print the test case number and the length of the largest palindrome.
Sample Input
abcbabcbabcba
abacacbaaaab
END
Sample Output
Case 1: 13
Case 2: 6

题意:
       找出字符中最长回文串,以END结束;

思路:

         只需要套用“马拉车”算法就可以了, Manacher算法 ,感谢这位大佬让我理解了Manacher的基本思路。
         找出回文串后在这个回文串内不用再次查找,复杂度为o(n),可以快速解决回文串问题;

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define M 1000010
using namespace std;
char str[M],str_new[2*M];
int p[2*M],len;
void init()
{
    len=strlen(str);
    str_new[0]='@';
    str_new[1]='#';
    for(int i=0; i<len; i++)
    {
        str_new[i*2+2]=str[i];
        str_new[i*2+3]='#';
    }
    str_new[len*2+2]='$';
}
void Manacher()
{
    memset(p,0,sizeof(p));
    int mx=0,di,ans=0;
    for(int i=1; i<len*2+2; i++)
    {
        if(mx>i)
            p[i]=min(mx-i,p[di*2-i]);
        else
            p[i]=1;
        for(; str_new[i-p[i]]==str_new[i+p[i]]; p[i]++);
        if(p[i]+i>mx)
            mx=p[i]+i,di=i;
        ans=max(ans,p[i]);
    }
    printf("%d\n",--ans);
}
int main()
{
    int t=1;
    while(~scanf("%s",str))
    {
        if(!strcmp(str,"END"))
            break;
        printf("Case %d: ",t++);
        init();
        Manacher();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值