CGL_3_B——Is-Convex(判凸包)

Is-Convex

 

For a given polygon g, print "1" if g is a convex polygon, "0" otherwise. Here, in a convex polygon, all interior angles are less than or equal to 180 degrees.

g is represented by a sequence of points p1, p2,..., pn where line segments connecting pi and pi+1 (1 ≤ i≤ n−1) are sides of the polygon. The line segment connecting pn and p1 is also a side of the polygon.

Input

g is given by coordinates of the points p1,..., pn in the following format:

n
x1 y1 
x2 y2
:
xn yn

The first integer n is the number of points. The coordinate of a point pi is given by two integers xi and yi. The coordinates of points are given in the order of counter-clockwise visit of them.

Output

Print "1" or "0" in a line.

Constraints

  • 3 ≤ n ≤ 100
  • -10000 ≤ xiyi ≤ 10000
  • No point of the polygon will occur more than once.
  • Two sides of the polygon can intersect only at a common endpoint.

Sample Input 1

4
0 0
3 1
2 3
0 3

Sample Output 1

1

 

Sample Input 2

5
0 0
2 0 
1 1
2 2
0 2

Sample Output 2

0

题目连接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=CGL_3_B

/*
本代码判断的凸包需要按顺序给出多边形的边。
*/
#include<bits/stdc++.h>
using namespace std;
typedef complex<double> qua;
vector<qua> v;
const double epx=1e-7;
int ccw(qua a,qua b,qua c)
{
    b-=a,c-=a,a=c*conj(b);
    if(a.imag()>epx) return 1;
    if(a.imag()<-epx) return -1;
    if(a.real()<-epx) return 2;
    if(abs(b)+epx<abs(c)) return -2;
    return 0;
}
bool judge_convex(vector<qua> &ve)
{
    int len_ve=ve.size();
    int flag1=1,flag2=1;
    for(int i=0;i<len_ve;i++)
    {
        if(ccw(ve[i],ve[(i+1)%len_ve],ve[(i+2)%len_ve])==-1) flag1=0;//逆时针方向能否成凸包
        if(ccw(ve[i],ve[(i+1)%len_ve],ve[(i+2)%len_ve])==1) flag2=0;//顺时针方向能否成凸包
    }
    return flag1|flag2;
}
int main()
{
    int n;
    double x,y;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%lf%lf",&x,&y);
        v.push_back(qua(x,y));
    }
    printf("%d\n",judge_convex(v));
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 6
    评论
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值