HDU - 1671——Phone List (字符串是否为另一字符串的前缀)

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits. Output For each test case, output “YES” if the list is consistent, or “NO” otherwise. Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
 

NOYES

题意:是否有一个字符串的为另一字符串的前缀。

思路:这题可以先排序(用长度或字典序排),在查找。因为有一个坑点,后出现的串为前一串的前缀(如先98346再983),这样的话用仅仅记录节点的方法会出错。或者可以记录整个串,再记录节点。如果到节点时,有这个串以外的串与它的节点相同,或者记录这个串时,发现有节点。则有一个字符串的前缀为另一字符串的前缀。
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
char a[15];
int trie[100000][11],tot,pan;
int book[100000];
bool base[100000];
void create_trie(char *str)
{
    int root=0;
    while(*str)
    {
        int di=*str-'0';
        if(trie[root][di]==0)
            trie[root][di]=++tot;
        root=trie[root][di];
        book[root]++;
        if(base[root])
            pan=1;
        str++;
    }
    base [root]=1;
    if(book[root]>1)//是否存在本身除外,所以>1
        pan=1;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        tot=0,pan=0;
        memset(trie,0,sizeof(trie));
        memset(book,0,sizeof(book));
        memset(base,0,sizeof(base));
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",a);
            create_trie(a);
        }
        if(pan)
            printf("NO\n");
        else
            printf("YES\n");
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值