poj1144-Network (求割点)

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N. No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. Fromtimetotimethepowersupplyfailsataplaceandthentheexchangedoesnotoperate. The officials from TLC realized that in such a case it can happen that besides the fact that the place withthefailureisunreachable, thiscanalsocausethatsomeotherplacescannotconnecttoeachother. In such a case we will say the place (where the failure occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them. Input The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the numberofaplacefollowedbythenumbersofsomeplacestowhichthereisadirectlinefromthisplace. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated by one space. Each block ends with a line containing just ‘0’. The last block has only one line with N = 0. Output The output contains for each block except the last in the input file one line containing the number of critical places. Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0 Sample Output

1

2

割点讲解博客:https://blog.csdn.net/zsyz_ZZY/article/details/79907335

                          https://www.cnblogs.com/en-heng/p/4002658.html

#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 110
using namespace std;
int mp[M][M],n,x,y,LOW[M],DFN[M],indox,ans,ap[M],pan;
void init()
{
    memset(DFN,-1,sizeof(DFN));
    memset(LOW,-1,sizeof(LOW));
    memset(mp,0,sizeof(mp));
    memset(ap,0,sizeof(ap));
    indox=ans=pan=0;
}
void tarjan(int u)
{
    DFN[u]=LOW[u]=++indox;
    for(int i=1; i<=n; i++)
    {
        if(mp[u][i])
        {
            if(DFN[i]==-1)
            {
                tarjan(i);
                LOW[u]=min(LOW[u],LOW[i]);
                if((LOW[i]>=DFN[u])&&u!=1&&!ap[u])
                {
                    ap[u]=1;
                    ans++;
                }
                else if(u==1)
                {
                    pan++;
                }
            }
            else
            {
                LOW[u]=min(LOW[u],DFN[i]);
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n),n)
    {
        init();
        while(~scanf("%d",&x),x)
        {
            while(getchar()!='\n')
            {
                scanf("%d",&y);
                mp[x][y]=1;
                mp[y][x]=1;
            }
        }
        tarjan(1);
        if(pan>1) ans++;
        printf("%d\n",ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值