HDU 4738 Caocao's Bridges (桥的权最小)

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.

Input

There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.

Output

For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.

Sample Input

3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0

Sample Output

-1
4

题意:曹操在赤壁战役中被诸葛亮和周瑜打败。但他不会放弃。曹操的军队还不擅长水战,所以他又想出了一个主意。曹操在长江上修建了许多岛屿,在这些岛屿的基础上,曹操的军队可以轻易地攻击周瑜的军队。曹操还修建了连接岛屿的桥梁。如果所有的岛屿都用桥梁连接起来,曹操的军队就可以很方便地部署在这些岛屿之间。周瑜无法忍受,他想摧毁曹操的一些桥梁,这样一个或多个岛屿就会和其他岛屿分开。但是周瑜只有一颗炸弹,那是诸葛亮留下的,所以他只能摧毁一座桥。周瑜必须派人携带炸弹摧毁大桥。桥上可能有守卫。轰炸队的士兵人数不能少于一座桥的警卫人数,否则任务就会失败。请至少算出周瑜到底要派多少士兵去完成岛上的分离任务。

坑点:有重边。

           如果是不是连通图输出0.

           如果守桥人数是0,至少要排一人。

思路:求桥的模板题。坑点多而已。

#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 1010
using namespace std;
struct path
{
    int to,nextt,v;
} A[M*M*2];
int head[M],DFN[M],LOW[M];
int n,m,tot,carry,indox,ans;
void init()
{
    ans=0x3f3f3f3f;
    carry=tot=indox=0;
    memset(head,-1,sizeof(head));
    memset(DFN,-1,sizeof(DFN));
    memset(LOW,-1,sizeof(LOW));
}
void add(int x,int y,int v)
{
    A[tot].to=y;
    A[tot].v=v;
    A[tot].nextt=head[x];
    head[x]=tot++;
}
void tarjan(int u,int p)
{
    int tem;
    DFN[u]=LOW[u]=++indox;
    for(int i=head[u]; i!=-1; i=A[i].nextt)
    {
        tem=A[i].to;
        if(i==p) continue;
        if(DFN[tem]==-1)
        {
            tarjan(tem,i^1);
            LOW[u]=min(LOW[u],LOW[tem]);
            if(LOW[tem]>DFN[u])
            {
                ans=min(ans,A[i].v);
            }
        }
        else
        {
            LOW[u]=min(LOW[u],DFN[tem]);
        }
    }
}
int main()
{
    int x,y,v,flag;
    while(~scanf("%d%d",&n,&m),n||m)
    {
        init();
        flag=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&x,&y,&v);
            add(x,y,v);
            add(y,x,v);
        }
        for(int i=1; i<=n; i++)
        {
            if(DFN[i]==-1)
            {
                tarjan(i,-1);
                flag++;
            }

        }
        if(flag>1)
            printf("0\n");
        else if(ans>1000000)
            printf("-1\n");
        else if(ans==0)
            printf("1\n");
        else
            printf("%d\n",ans);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值