数算 字符串插入 数组

字符串插入
有两个字符串str和substr,str和substr的字符个数不超过10^5,只包含大小写字母和数字。(字符个数不包括字符串结尾处的’\0’。)将substr插入到str中ASCII码最大的那个字符后面,若有多个最大则只考虑第一个。
输入样例:
abcab eee
输出样例:
abceeeab

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
 string str1, str2;
 cin >> str1 >> str2;
 int len = str1.size();
 char Max = 0;
 int p = 0;
 for (int i = 0; i < len; i++)
 {
  if (str1[i] > Max)
  {
   Max = str1[i];
   p = i;
  }
 }
 string str3 = str1.substr(0, p + 1);
 str3 += str2;
 string str4 = str1.substr(p + 1, len - p - 1);
 str3 += str4;
 cout << str3 << endl;
 system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值