PTA 甲级 1004 Counting Leaves (30 分)

题目

N是树的节点数量 M是非叶子节点的数量

接下来M行:节点编号, 孩子节点的个数, 每个孩子节点的编号

(所有编号用两位数来表示,其实只需要输入,直接cin根本没毛病)

求:从根节点到叶子节点 , 每一层没有孩子的节点数量

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority levelstarting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

分析

第一个30’ 的题目1A。卧槽,开熏!

利用的BFS和队列。

 节点中存储了节点所在的层数,在进队列之前进行修改。优先队列的也即按照层数进行排序。

其实并不需要用优先队列,普通队列就行了。(一个上午闲着没事突然想到的zz)

代码

#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int n , m;
const int maxn = 105;
int lnum[maxn]; //没有孩子的节点数量
int layermax = 0;
struct Node
{
    int id;
    int layer ;
    int childnum = 0;
    int child[maxn];
    friend bool operator < ( Node a , Node b)
    {
        return a.layer > b.layer;
    }
}node[maxn];

int bfs(int start)
{
    priority_queue<Node> Q;
    while(!Q.empty()) Q.pop();

    node[start].layer = 0;
    Q.push(node[start]);
    while(!Q.empty())
    {
        Node tmp = Q.top() ;
        Q.pop();
       
        int tmpnum = tmp.childnum;
        int tmplay = tmp.layer;
        layermax = max(layermax , tmplay);
        if(tmpnum == 0) lnum[tmplay]++;
        for(int i = 0 ; i < tmpnum ;i++)
        {
            Node tmp2 = node[tmp.child[i]];
            tmp2.layer = tmplay + 1;
            Q.push(tmp2);
        }
    }
}

int main()
{
  
    while(scanf("%d" ,&n) != EOF)
    {

        if( n == 0) return 0;
        cin >> m;

        for(int i = 0 ; i < m ; i++)
        {
            int id , k;
            cin >> id >> k;
            node[id].childnum = k;
            node[id].id = id;
            for(int i = 0 ; i < k ;i++)
            {
                cin >> node[id].child[i];
               
            }
        }
       
       bfs(1);

       for(int i = 0 ; i <= layermax ; i++)
       {
           if(i != layermax) cout << lnum[i] << " ";
           else cout << lnum[i];
       }


    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值