PTA甲级——7-5 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification:

The input consists of several test cases, each starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format ID K ID[1] ID[2] … ID[K] where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.
Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

For example, the first sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:

2 1
01 1 02
1 0
7 4
01 2 02 03
06 1 07
02 2 04 05
03 1 06
0 0

Sample Output:

0 1
1
0 0 2 1

本题和7-5 Counting Leaves相似,只是不需要处理多组输入。下面给出的代码具有处理多组输入的能力。

先要做出本题,需要掌握以下两点。
(1)使用邻结矩阵保存树的信息(实际上使用邻结矩阵来保存信息会浪费大量的内存,当数据量大时一般使用邻结表来保存数据,为了专注于本题,这里就不展开说明了)
(2)设计dfs来获取树的每层叶子数量(将bfs,dfs融入图树是十分常见的),注意参数的设计!

下面给出代码及注释进一步讲解

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

vector<int> tree[100]; //使用邻结矩阵存树,使用vector可以更加方便的获取树的信息(不要被二叉树限制思维,实际上树的度数是根据实际问题确定的)
int maxdep, book[100]; //book用来保存每一层的叶结点数

void dfs(int index, int dep) //将深度作为参数传入可以直接记录对应层的叶结点数
{
	maxdep = max(maxdep, dep); //注意每次搜索开始都应该试着更新最大深度,大家可以想想如果把该语句放在if后会发生什么情况
	if (tree[index].size() == 0) { book[dep]++; return; }
	for (int i = 0; i < tree[index].size(); i++) //根据vector的大小,也就是儿子的个数直接判所是否是叶节点
		dfs(tree[index][i], dep + 1);
}

int main()
{
	int n, m, f, k, s;
	while (cin >> n >> m && n)
	{
		memset(book, 0, sizeof(book));
		for (int i = 0; i < 100; i++) tree[i].clear();
		maxdep = -1;

		for (int i = 0; i < m; i++) //读入树
		{
			cin >> f >> k;
			for (int j = 0; j < k; j++) { cin >> s; tree[f].push_back(s); }
		}
		dfs(1, 0); //题目默认1号为根节点,省去了找根节点的步骤
		cout << book[0];
		for (int i = 1; i <= maxdep; i++) cout << ' ' << book[i];
		cout << endl;
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值