PAT 甲级 1021 Deepest Root (25分)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components
考点:树的直径
#include<iostream>
#include<set>
#include<cstring>
using namespace std;
const int N = 1e4 + 10;
int h[N],e[3*N],ne[3*N],fa[N],dist[N],id1,id2,idx,n;
set<int> s;
void add(int x,int y){
    e[idx] = y;
    ne[idx] = h[x];
    h[x] = idx++;
}

void init(){
    for (int i = 1; i <= n;++i)
        fa[i] = i;
}

int find(int x){
    if (x == fa[x]) return x;
    return find(fa[x]);
}

void dfs(int u,int fa,int distance){
    dist[u] = distance;
    for (int i = h[u]; i != -1; i = ne[i]){
        int v = e[i];
        if (v != fa){
            dfs(v,u,distance + 1);
        }
    } 
}

int main(){
    memset(h,-1,sizeof h);
    cin>>n;
    init();
    for (int i = 1; i < n; ++i){
        cin>>id1>>id2;
        add(id1,id2);
        add(id2,id1);
        if (find(id1) != find(id2)){
            fa[find(id2)] = fa[id1];
        }
    }
    int cnt = 0;
    for (int i = 1; i <= n; ++i)
        if (i == fa[i]) cnt++;

    if (cnt != 1){
        cout<<"Error: "<<cnt<<" components";
        return 0;
    }

    dfs(1,-1,0);

    int max_dist = 0,u;

    for (int i = 1; i <= n; ++i){
        if (max_dist < dist[i]){
            max_dist = dist[i];
            u = i;
        }
    }

    for (int i = 1; i <= n; ++i){
        if (max_dist == dist[i])
            s.insert(i);
    }  

    dfs(u,-1,0);

    max_dist = 0;
    for (int i = 1; i <= n; ++i){
        if (max_dist < dist[i]){
            max_dist = dist[i];
        }
    }

    for (int i = 1; i <= n; ++i){
        if (max_dist == dist[i])
            s.insert(i);
    }

    for (auto x:s) cout<<x<<endl;

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值