PAT 甲级 1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
思路: 模拟即可,我记得这道题还出现在《剑指offer》这本书里过

1. 如果当前要出栈的元素不等于栈顶元素的话,就试着先把后面的元素入栈(还要注意最多m个元素)

2. 当没法再将后面的元素入栈入栈时,如果栈顶元素还不和当前要pop的元素相同的话,就说明这个sequence是不可行的

3. 如果提前将1到n个元素入栈了,之后就只能弹出操作了,如果栈顶元素不同于要弹出的元素就说明这个sequence是不可行的
#include<iostream>
#include<stack>
#include<vector>
using namespace std;
vector<int> vect;
stack<int> stk;
int n,m,k,flag,index,t;

int main(){
    vect.resize(1010);
    cin>>m>>n>>k;

    for (int i = 0 ; i < k; ++i){
        flag = 1;
        for (int j = 0; j < n; ++j)  cin>>vect[j];

        while(stk.size()) stk.pop();

        index = 1;
        for (t = 0; t < n; ++t){
            if (index > n) break;
            while(stk.size() == 0 || (vect[t] != stk.top() && stk.size() < m)){
                stk.push(index);
                index++;
                if (index > n) break;
            }
            if (vect[t] == stk.top())
                stk.pop();
            else{
                flag = 0;
                break;
            }
        }
        if (flag){
            for ( ;t < n; ++t){
                if (stk.size() == 0){
                    flag = 0;
                    break;
                }
                if (vect[t] == stk.top())
                    stk.pop();
                else flag = 0;
            }
        }

        if (flag)
            puts("YES");
        else puts("NO");    
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值