hdu4707-Pet(深度搜索)

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=4707

题目原文:

Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3659    Accepted Submission(s): 1730


 

Problem Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

 

 

Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

 

 

Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

 

 

Sample Input

 

2
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9
10 1
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

 

 

Sample Output

 

2

6


 

题目大意:

        给一棵树,n个节点,没有环且都连通,问距离大于d的节点个数。

解题思路:

        对距离小于等于d的节点进行深搜。n-ans就是答案。 

AC代码:

#include <cstdio>
#include <vector>
using namespace std;

const int N = int(1e5 + 5);
vector<int> vec[N];
int g_n, g_d;

void init()
{
    int i;
    for (i = 0; i < g_n; i++)
    {
        vec[i].clear();
    }
}

// 查找距离小于D的节点个数
int dfs(int idx, int dist)
{
    if (dist > g_d) return 0;
    int ans = 1;
    vector<int>::iterator it;
    for (it = vec[idx].begin(); it != vec[idx].end(); it++)
    {
        ans += dfs(*it, dist + 1);
    }
    return ans;
}

int main()
{
    int T, i, a, b;
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d", &g_n, &g_d);
        init();
        for (i = 0; i < g_n - 1; i++)
        {
            scanf("%d%d", &a, &b);
            vec[a].push_back(b);
        }
        printf("%d\n", (g_n - dfs(0, 0)) );
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值