POJ2155-Matrix(二维树状数组)

题目链接

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.

Sample Input

1

2 10

C 2 1 2 2

Q 2 2

C 2 1 2 1

Q 1 1

C 1 1 2 1

C 1 2 1 2

C 1 1 2 2

Q 1 1

C 1 1 2 1

Q 2 1

Sample Output

1

0

0

1


题意

平面矩阵上0-1翻转,一开始全部是0,有两个操作:C,给一个矩阵,所有翻转;Q,给一个点,输出0或者1.

思路

对于只有0-1的,如果是1维,翻转给定的区域,可以转化为增加两个点的值。比如1-10的数组a[ ],翻转1-4,可以转为增加a[1]和a[5],确认a[i]是多少的时候,统计前i项和,如果是偶数则是0,奇数则是1。a[i]相当于第i个区域翻转的次数

二维的类似,转为增加4个点的值,统计(i,j)时,求横坐标小于等于i,纵坐标小于等于j的 i * j个区域的总和,在%2。

二维树状数组


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define ll long long
#define inf 0x3f3f3f3f
#define lowbit(x) (x& -x)
using namespace std;
const int N = 1010;
int c[N][N],n,m;

int sum(int x,int y)
{
    int res = 0;
    for(int i = x;i>0;i-=lowbit(i)){
        for(int j = y;j>0;j-=lowbit(j)){
            res += c[i][j];
        }
    }
    return res;
}

void add(int x,int y)
{
    int i,j;
    for(int i = x;i<=n;i+=lowbit(i)){
        for(int j = y;j<=n;j+=lowbit(j)){
            c[i][j]++;
        }
    }
}

int main()
{
    int T,x1,x2,y1,y2;
    char ch;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(c,0,sizeof(c));
        while(m--)
        {
            scanf(" %c",&ch);
            if(ch=='C'){
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                add(x1,y1);
                add(x1,y2+1);
                add(x2+1,y1);
                add(x2+1,y2+1);
            }
            else if(ch=='Q'){
                scanf("%d%d",&x1,&y1);
                printf("%d\n",sum(x1,y1)&1);
            }
        }
        printf("\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值